某单傡内部有200多个计算机终端上网,通过H3C MSR3620 路由器作为出口网关,由于有很多用户随意下载和浏览视频,很容易造成网络拥堵,通过调整带宽限速来解决问题。
互联网接入为拔号上网,典型配置如下:
telnet server enable
#
dialer-group 1 rule ip permit
dialer-group 2 rule ip permit
#
interface Dialer0
bandwidth 100000
ppp chap password cipher $c$3$fwpd22HVP4TVgwRXMaNSkBu+8H+N50LBVA==
ppp chap user username@hrtn-jz
ppp ipcp dns admit-any
ppp ipcp dns request
ppp pap local-user username@hrtn-jz password cipher password***
dialer bundle enable
dialer-group 2
dialer timer idle 0
dialer timer autodial 5
ip address ppp-negotiate
nat outbound
#
interface Dialer1
bandwidth 100000
ppp chap password cipher password***
ppp chap user username@hrtn-jz
ppp pap local-user username@hrtn-jz password cipher password***
dialer bundle enable
dialer-group 1
dialer timer idle 0
dialer timer autodial 5
ip address ppp-negotiate
nat outbound
#
interface NULL0
#
interface GigabitEthernet0/0
port link-mode route
combo enable copper
ip address 192.168.0.1 255.255.252.0
tcp mss 1024
#
interface GigabitEthernet0/1
port link-mode route
description Multiple_Line
tcp mss 1024
pppoe-client dial-bundle-number 0
pppoe-client dial-bundle-number 1
#
zone-pair security source Any destination Any
object-policy apply ip Any-Any
#
line vty 0 4
user-role level-15
user-role network-admin
set authentication password hash telnetpassword****
#
ip route-static 0.0.0.0 0 Dialer1
ip route-static 0.0.0.0 0 Dialer0
acl basic 2000
rule 0 permit source 10.0.0.0 0.0.0.255
rule 1 deny
#
ip http enable
#
增加流控策略,限制192.168.0.1-192.168.0.9 ,192.168.0.21-192.168.0.253 上传下载为2000M, 192.168.0.10-192.168.0.20 不限速
qos carl 1 destination-ip-address range 192.168.0.1 to 192.168.0.9 per-address
qos carl 2 source-ip-address range 192.168.0.1 to 192.168.0.9 per-address
qos carl 3 destination-ip-address range 192.168.0.21 to 192.168.0.253 per-address
qos carl 4 source-ip-address range 192.168.0.21 to 192.168.0.253per-address
dialer-group 1
dialer timer idle 0
dialer timer autodial 5
ip address ppp-negotiate
qos car inbound carl 1 cir 2000 cbs 125000 ebs 0 green pass red discard yellow pass
interface Dialer1
qos car inbound carl 1 cir 2000
qos car outbound carl 2 cir 2000
qos car inbound carl 3 cir 2000
qos car outbound carl 4 cir 2000